Problem Statement :-
Given a time in -hour AM/PM format, convert it to military (24-hour) time.
Note: - 12:00:00AM on a 12-hour clock is 00:00:00 on a 24-hour clock.
- 12:00:00PM on a 12-hour clock is 12:00:00 on a 24-hour clock.
Example
Return '12:01:00'.
Return '00:01:00'.
Function Description
Complete the timeConversion function in the editor below. It should return a new string representing the input time in 24 hour format.
timeConversion has the following parameter(s):
- string s: a time in hour format
Returns
- string: the time in hour format
Input Format
A single string that represents a time in -hour clock format (i.e.: or ).
Constraints
- All input times are valid
Sample Input 0
07:05:45PM
Sample Output 0
19:05:45
import java.io.*;
import java.math.*;
import java.security.*;
import java.text.*;
import java.util.*;
import java.util.concurrent.*;
import java.util.regex.*;
class Result {
public static String timeConversion(String s) {
String resultTime = "";
int finalTime = 0;
int dateStringLen = s.length();
String dateFormat = s.substring(dateStringLen - 2, dateStringLen);
int hourTime = Integer.parseInt(s.substring(0, 2));
if (dateFormat.equals("PM")) {
if (hourTime == 12) {
resultTime = s;
} else {
finalTime = 12 + hourTime;
resultTime = s.replace(s.substring(0, 2), String.valueOf(finalTime));
}
}
if (dateFormat.equals("AM")) {
if (hourTime == 12) {
resultTime = s.replace(s.substring(0, 2), "00");
}else {
resultTime = s;
}
}
resultTime = resultTime.replace(s.substring(dateStringLen - 2, dateStringLen), "");
return resultTime;
}
}
public class Solution {
public static void main(String[] args) throws IOException {
BufferedReader bufferedReader = new BufferedReader(new InputStreamReader(System.in));
BufferedWriter bufferedWriter = new BufferedWriter(new FileWriter(System.getenv("OUTPUT_PATH")));
String s = bufferedReader.readLine();
String result = Result.timeConversion(s);
bufferedWriter.write(result);
bufferedWriter.newLine();
bufferedReader.close();
bufferedWriter.close();
}
}